好消息,超酷的在线虚拟网络实验室上线了!点击开始实验

为获得更好的浏览效果,建议您使用 Firefox 或者 Chrome 浏览器



4.1.5    MP典型配置

【需求】

RouterARouterB通过MP链路互通,实现更高的带宽和可靠性。

【组网图】

4.1.6.1 将链路直接绑定到VT上典型配置

【配置脚本】

RouterA配置脚本

#

sysname RouterA

#

radius scheme system

#

domain system

#

interface Virtual-Template0          /创建VT接口/

ip address 10.1.1.1 255.255.255.0

#

interface Serial1/0

link-protocol ppp

ppp mp Virtual-Template 0        /将物理端口和VT0进行绑定/

#

interface Serial1/1

link-protocol ppp

ppp mp Virtual-Template 0       /将物理端口和VT0进行绑定/

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return

RouterB配置脚本

#

sysname RouterB

#

radius scheme system

#

domain system

#

interface Virtual-Template0          /创建VT接口/

ip address 10.1.1.2 255.255.255.0

#

interface Serial1/0

link-protocol ppp

ppp mp Virtual-Template 0       /将物理端口和VT0进行绑定/

#

interface Serial1/1

link-protocol ppp

ppp mp Virtual-Template 0       /将物理端口和VT0进行绑定/

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return

 

【验证】

通过查看disp ppp mp信息,两条物理链路都已经绑定到VT0上。并且都可以互相ping通对方的IP地址

[RouterA]disp ppp mp

Template is Virtual-Template0                                                  

max-bind: 16, min-fragment: 128                                                

 Bundle ef63fe328e5d, 2 members, slot 0, Master link is Virtual-Template0:0    

 Peer's endPoint descriptor: ef63fe328e5d                                      

 Bundle Up Time: 2006/01/27  07:50:38:696                                      

  0 lost fragments, 5 reordered, 0 unassigned, 0 interleaved,                  

 sequence 4/5 rcvd/sent                                                        

 The member channels bundled are:                                              

      Serial1/0        Up-Time:2006/01/27  07:50:38:696                      

      Serial1/1        Up-Time:2006/01/27  07:51:47

 

4.1.6.2按用户名查找VT进行绑定的典型配置

【配置脚本】

RouterA配置脚本

#

sysname RouterA

#

ppp mp user rtb bind Virtual-Template 0    /指定用户rtb绑定到对应的VT0/

#

radius scheme system

#

domain system

#

local-user rtb            /创建用来验证的本地帐号/

password simple rtb

service-type ppp

#

interface Virtual-Template0     /创建VT接口/

ip address 10.1.1.1 255.255.255.0

#

interface Serial1/0

link-protocol ppp

ppp authentication-mode pap

ppp pap local-user rta password simple rta

ppp mp

#

interface Serial1/1

link-protocol ppp

ppp authentication-mode pap           /使能PAP验证/

ppp pap local-user rta password simple rta     /送给对端的用户名密码/

ppp mp

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return

RouterB配置脚本

#

sysname RouterB

#

ppp mp user rta bind Virtual-Template 0    /指定用户rta绑定到对应的VT0/

#

radius scheme system

#

domain system

#

local-user rta              /创建用来验证的本地帐号/

password simple rta

service-type ppp

#

interface Virtual-Template0      /创建VT接口/

ip address 10.1.1.2 255.255.255.0

#

interface Serial1/0

link-protocol ppp

ppp authentication-mode pap

ppp pap local-user rtb password simple rtb

ppp mp

#

interface Serial1/1

link-protocol ppp

ppp authentication-mode pap           /使能PAP验证/

ppp pap local-user rtb password simple rtb   /送给对端的用户名密码/

ppp mp

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return

 

【验证】

通过查看disp ppp mp信息,两条物理链路都已经绑定到VT0上。并且都可以互相ping通对方的IP地址

[RouterA]disp ppp mp                                               

                                                                               

Template is Virtual-Template0                                                   

max-bind: 16, min-fragment: 128                                                

 Bundle ef63fe328e5d/rtb, 2 members, slot 0, Master link is Virtual-Template0:0

 Peer's endPoint descriptor: ef63fe328e5d                                       

 Bundle Up Time: 2006/01/27  08:15:53:664                                      

  0 lost fragments, 0 reordered, 0 unassigned, 0 interleaved,                  

 sequence 0/0 rcvd/sent                                                        

 The member channels bundled are:                                              

      Serial1/0        Up-Time:2006/01/27  08:16:17:78                       

      Serial1/1        Up-Time:2006/01/27  08:15:53:664

 

【提示】

使用该方式,要求两遍的设备的接口上都必须进行用户认证。配置复杂,不推荐使用。

 

4.1.6.3将链路绑定到Mp-group接口的典型配置

【配置脚本】

RouterA配置脚本

#

sysname RouterA

#

radius scheme system

#

domain system

#

interface Serial1/0

link-protocol ppp

ppp mp Mp-group 0            /物理端口和mp-group进行绑定/

#

interface Serial1/1

link-protocol ppp

ppp mp Mp-group 0            /物理端口和mp-group进行绑定/

#

interface Mp-group0                /创建mp-group/

ip address 10.1.1.1 255.255.255.0

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return

RouterB配置脚本

#

sysname RouterB

#

radius scheme system

#

domain system

#

interface Serial1/0

link-protocol ppp

ppp mp Mp-group 0            /物理端口和mp-group进行绑定/

#

interface Serial1/1

link-protocol ppp

ppp mp Mp-group 0            /物理端口和mp-group进行绑定/

#

interface Mp-group0                  /创建mp-group/

ip address 10.1.1.2 255.255.255.0

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return

 

【验证】

通过查看disp ppp mp信息,两条物理链路都已经绑定到mp-group 0上。并且都可以互相ping通对方的IP地址

[Quidway]disp ppp mp

Mp-group is Mp-group0

max-bind: 16, min-fragment: 128

Bundle Multilink, 2 members, slot 0, Master link is Mp-group0

Peer's endPoint descriptor: a3550d163e28

Bundle Up Time: 2006/01/27  08:26:44:79

0 lost fragments, 5 reordered, 0 unassigned, 0 interleaved,

sequence 4/5 rcvd/sent

Member channels: 2 active, 0 inactive

Serial1/0        Up-Time:2006/01/27  08:26:44:79

Serial1/1        Up-Time:2006/01/27  08:26:51:781

 

【提示】

1、可以有三种MP的绑定方式:

1)将链路直接绑定到VT上;

`   2)按用户名查找VT

3)将链路绑定到Mp-group接口。

推荐使用13两种方法,不建议使用第2种方式。

 

2、Mp-group绑定方式和使用VT绑定方式基本相同,只是需要创建mp-group,并将物理端口和mp-group进行绑定。

 

X Close
X Close